Materi Multimedia 1


PROTOKOL JARINGAN SISTEM MULTIMEDIA
Agenda
•         Introduksi
•         Jaringan Komputer
•         Protokol
•         Perbedaan antara berbagai protokol
•         Karakteristik Data Multimedia

Introduksi
•         Kebutuhan akan sistem multimedia tidak cukup menggunakan desktop
•         Kadang perlu dilakukan untuk keperluan mobile
•         Perlu juga dilakukan distribusi secara online-> diperlukan suatu jaringan.
•         Sistem terdistribusi -> protokol untuk berkomunikasi.

Jaringan Komputer
•         Jaringan komputer : seperangkat komputer otonom yang secara eksplisit terlihat (secara eksplisit teralamati) dan terhubung satu-sama lain. [Tanembaum, 1996]
•         Tipe jaringan komputer:
–        Local Area Network (LAN) : jaringan kecepatan tinggi pada suatu lingkungan lokal tertentu.
–        Metropolitan Area Network (MAN) : jaringan kecepatan tinggi untuk node yang terdistribusi dalam jarak jauh (biasanya untuk satu kota atau suatu daerah besar)
–        Wide Area Network (WAN), komunikasi untuk jarak yang sangat jauh. Contoh: Internet
–        Wireless Network, peralatan end-user untuk mengakses jaringan dengan menggunakan transmisi radio pendek atau sedang.
•         Wireless WAN : GSM (sampai 20 Kbps)
•         Wireless LAN/MAN : WaveLAN (2-11 Mbps, sampai 150 m)
•         Wireless PAN (Personal Area Network) : bluetooth (sampai 2 Mbps, jarak < 10 m)





Protokol
•         Protokol adalah aturan-aturan yang disetujui tentang bagaimana komunikasi diproses antara 2 node.
–        Protokol jaringan yang paling umum digunakan sekarang ini adalah protokol jaringan berbasis IP (Internet Protocol)
•         Jenis Protokol :
–        Model Tiga Lapisan (Three-Layer Protocol)
–        OSI (Open System Interconnection)
–        TCP/IP

Perbedaan OSI Network Layer dengan TCP/IP Layer




































Open System Interconnection (OSI)







Protokol IP (Internet Protocol)
•         Berdasarkan RFC 791
•         Fungsi penting IP:
–        Menentukan jalur yang ditempuh antara pengirim dan penerima.
–        Switching : memindahkan paket dari input router ke output router yang sesuai
–        Call Setup : beberapa arsitektur jaringan membutuhkan setup koneksi dahulu.
•         IPv4 (tahun 1982) menggunakan panjang alamat sebesar 32 bit yang dibagi menjadi 4 komponen, sedangkan IPv6 menggunakan 128 bit
•         IP versi 6 distandarisasi dengan RFC 2460
–        Alamat menggunakan : (semicolon) hexadesimal
69dc:8864:ffff:ffff:0:1280:8c0a:ffff
–        Yang sama jika ditulis secara desimal dengan IPv4
105.220.136.100.255.255.255.255.0.18.128.140.10.255.255

Protokol TCP (Transmission Control Protocol)
•         RFC 793
•         Menyediakan komunikasi logika antara proses aplikasi yang berjalan pada host yang berbeda
•         Ada dua protokol : TCP dan UDP (User Datagram Protocol)
–        Protocol UDP. Menyediakan layanan transport unreliable dan connectionless:
•         Tidak menjamin urutan pengiriman
•         Setiap paket memiliki alamat tujuan
•         Duplikasi message sangat dimungkinkan
•         Memfasilitasi multicasting (transmisi data pada subset network yang telah disepakati)
–        Contoh: semua protokol multimedia yang tidak memerlukan error koreksi. Misal RTP (Real-time Transport Protocol)
–        Protocol TCP
•         Menyediakan layanan transport connection oriented dan reliable:
•         Adanya pengecekan error menggunakan mekanisme acknoledgment
•         Dijaga urutan message
•         Segmentasi data stream dari lapisan aplikasi
•         Komunikasi duplex (2 arah)
–        Tidak cocok untuk protocol multimedia, karena:
•         TCP akan menghentikan pengiriman data jika terjadi kemacetan.
•         Tidak real-time
•         Terjadi timbal balik dari penerima ke pengirim jika pengoriman sukses. Pada multimedia tidak diperlukan error koreksi, TCP retransmission dapat menyebabkan jitter (perbedaan waktu antara waktu keberangkatan dan kedatangan).
•         Protokol HTTP
–        The protocol yang paling populer
–        Pada RFC 2616, HTTP didefinisikan sebagai :
•         “The Hypertext Transfer Protocol (HTTP) is an application-level protocol for distributed, collaborative, hypermedia information systems.”
•         HTTP 1/0 (non-persistent) dan HTTP 1/1 (persistent)
–        Bersifat stateless (server tidak memelihara informasi dari client sebelumnya)
–        Method umum: GET, POST, dan HEAD
•         Kode status HTTP:
–        1xx: informational
–        2xx: successful, e.g. 200 OK
–        3xx: redirection
•         301 Moved Permanently
•         304 Not Modified
–        4xx: Client Error
•         400 Bad Request
•         401 Unauthorized
•         403 Forbidden
•         404 Not Found
–        5xx: Server Error
•         501 Not Implemented
•         503 Service Unavailable
–        HTTP mendukung : cookie dan HTTP Authentication

Karakteristik Data Multimedia
•         Terutama difokuskan pada Continous media (video dan audio)
•         Memliki karakteristik:
–        Voluminous
•         Membutuhkan data rate tinggi dan berukuran besar
–        Real-time and Interactive
•         Membutuhkan low delay
•         Membutuhkan sinkronisasi dan interaktif


 

MULTIMEDIA DAN INTERNET
Agenda
•         Introduksi
•         MIME
•         WWW dan HTML
•         Plug – in
•         Multimedia Streaming
•         QoS
•         Kualitas Video

Introduksi
•         Sejarah Internet.
–        Bermula dari riset yang didanai oleh ARPA (Advanced Research Project Agency) Dephan AS ->ARPANET untuk keperluan militer.
–        Berkembang terhubung dengan universitas, militer, pemerintahan dalam interkoneksi menggunakan jaringan lokal.
•         Alamat Internet.
–        Digunakan sebagai penanda dari suatu situs
–        Dalam bentuk :            Protocol://hostname/[path/[filename]]
                                                http://geocities.yahoo.com/arriwidyanto
•         Top-level Domain
–        Merupakan suatu nama untuk mengakomodasi semua pengguna internet.
–        Contoh : com, edu, gov, int, mil, net, org dan kode kode negara.
–        Whitehouse.gov dan whitehouse.com merupakan alamat dengan penghuni yang berbeda.

0 komentar:

Posting Komentar